BMW i
Forum for the BMW i3, i4 and i8
BMW i3 BMW i8
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

  BMW i Forums > BMW i3 Forums > BMW i3 General Discussion

Post Reply
 
Thread Tools Search this Thread
      02-10-2019, 03:33 PM   #1
Myi3reXhandy
Enlisted Member
8
Rep
35
Posts

Drives: i3 Rex 2015
Join Date: Jan 2019
Location: 18301

iTrader: (0)

Engine light on

Hi guys I got this light on my i3 Rex. 2105 about 20g miles I been looking online if theres anything related but most of the post I found was could be a bug on software, on any case I'm open to hear if anyone in here has the same issue
Attached Images
 
__________________
i3 HANDY MOVIL
Appreciate 0
      02-11-2019, 10:34 AM   #2
PBNB
Enlisted Member
11
Rep
34
Posts

Drives: 2015 i3 REX
Join Date: Jul 2018
Location: Vancouver, B.C.

iTrader: (0)

The check engine light is most likely related to the REX. Do you have a code reader to extract the code that is setting off the light? You need that to be able to understand why the light is on. If you use Bimmercode, your OBDII plug in should help you read the code however, you might need to download another app to read the code and even clear it.

I had a check engine light about 8 months ago but it was related to the gas cap not being tight.
Appreciate 0
      02-11-2019, 10:47 AM   #3
DonC
Lieutenant
United_States
23
Rep
426
Posts

Drives: 2013 X3 3.5i M sport, etc
Join Date: Aug 2012
Location: near Seattle

iTrader: (0)

My engine light came on and it was for the REX oil change. I had the dealer complete the change (covered maintenance) and no longer have the light. If you have the BMW app you can see the service required.
__________________
2013 X3 3.5i AW,Msprt,rear fogs,PS,CP, Tech, etc...
Other cars
2005 S2000
2018 i3S
Appreciate 0
      02-11-2019, 10:51 AM   #4
Myi3reXhandy
Enlisted Member
8
Rep
35
Posts

Drives: i3 Rex 2015
Join Date: Jan 2019
Location: 18301

iTrader: (0)

Quote:
Originally Posted by DonC View Post
My engine light came on and it was for the REX oil change. I had the dealer complete the change (covered maintenance) and no longer have the light. If you have the BMW app you can see the service required.
I did get a code reader on it but I look it up online and all about a Malibu car nothing of i3 bmw
Attached Images
   
__________________
i3 HANDY MOVIL
Appreciate 0
      02-12-2019, 10:35 AM   #5
afadeev
Colonel
afadeev's Avatar
1080
Rep
2,491
Posts

Drives: F80 M3
Join Date: Jan 2012
Location: NYC

iTrader: (0)

Quote:
Originally Posted by Myi3reXhandy View Post
Hi guys I got this light on my i3 Rex. 2105 about 20g miles I been looking online if theres anything related but most of the post I found was could be a bug on software, on any case I'm open to hear if anyone in here has the same issue
I used to get CE lights on my ex-REX every spring and every fall. Something about temp fluctuations got on-board sensors upset.
At first, I would get them read/reset at the dealer. Later on, I ignored them (leased car) and they would clear on their own after X-many ignition cycles.

Yours could be similar, or could be something serious.

Quote:
Originally Posted by Myi3reXhandy View Post
I did get a code reader on it but I look it up online and all about a Malibu car nothing of i3 bmw
You need BMW-specific ODB-II code reader.
The generic stuff above is failing to read/interpret BMW codes.
You could try resetting them, and see if they come back. That would be one way to confirm if the issue is ongoing, or was something spurious.

HTH,
a
__________________
'19 TM3P (BK/BK)
'15 F80 M3 (SO/SS)
ex-'17 I01 i3-BEV (PB/DD), ex-'15 I01 i3-REX, ex-E90, E46, E36's, E30's
Appreciate 0
      02-12-2019, 10:37 AM   #6
Myi3reXhandy
Enlisted Member
8
Rep
35
Posts

Drives: i3 Rex 2015
Join Date: Jan 2019
Location: 18301

iTrader: (0)

Quote:
Originally Posted by afadeev View Post
Quote:
Originally Posted by Myi3reXhandy View Post
Hi guys I got this light on my i3 Rex. 2105 about 20g miles I been looking online if theres anything related but most of the post I found was could be a bug on software, on any case I'm open to hear if anyone in here has the same issue
I used to get CE lights on my ex-REX every spring and every fall. Something about temp fluctuations got on-board sensors upset.
At first, I would get them read/reset at the dealer. Later on, I ignored them (leased car) and they would clear on their own after X-many ignition cycles.

Yours could be similar, or could be something serious.

Quote:
Originally Posted by Myi3reXhandy View Post
I did get a code reader on it but I look it up online and all about a Malibu car nothing of i3 bmw
You need BMW-specific ODB-II code reader.
The generic stuff above is failing to read/interpret BMW codes.
You could try resetting them, and see if they come back. That would be one way to confirm if the issue is ongoing, or was something spurious.

HTH,
a
I did isn't showing on so far so hopefully was a bug or something I'm taking it for service in March
Thanks
__________________
i3 HANDY MOVIL
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:37 PM.




bmw
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST