BMW i
Forum for the BMW i3, i4 and i8
BMW i3 BMW i8
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

  BMW i Forums > BMW i8 Forums > BMW i8 General Discussion

Post Reply
 
Thread Tools Search this Thread
      01-15-2019, 04:29 AM   #1
zorgzx
Private
zorgzx's Avatar
Denmark
11
Rep
60
Posts

Drives: I8 Coupe
Join Date: Aug 2018
Location: Denmark

iTrader: (0)

i8 drive mode hack

Has anyone attempted to hack the drivemodes of the i8.

I really enjoy the sportmode on especially the german autobahn and nightdiriving in general on motorways. The E-assisted overtaking powerboost available from half throttle gives it a V8 like surge i really enjoy.

Unfortunately it allso gives me the agressive throttle map and edgy damping.

I'd love to hack so I can use sportmode without those.

Allso I'd love to be able to use max-e mode without worring about activating the petrol engine, so a E-only unless you hit the kick-down stop on the throttle would be lovely so I can enjoy the torque-fest form no revs the E-motor can give.

Anyone dabbled in it ?
Appreciate 0
      01-15-2019, 01:54 PM   #2
arijaycomet
New Member
7
Rep
16
Posts

Drives: 2015 BMW i8
Join Date: Mar 2016
Location: Cleveland, Ohio USA

iTrader: (0)

I cannot help you with the first question, but for the second one I can tell you that already works as described. If you press the eDrive button (below the start/stop button) the car should remain in E-only, unless you push down past the kick-down button. That is how my 2015 works.
Appreciate 1
Aye-eight490.00

      01-16-2019, 03:26 AM   #3
zorgzx
Private
zorgzx's Avatar
Denmark
11
Rep
60
Posts

Drives: I8 Coupe
Join Date: Aug 2018
Location: Denmark

iTrader: (0)

Mine did too. But change behavior after 2018 software Or the cold arrived.

Have you had software upgraded / tried it in the cold ?
Appreciate 0
      01-16-2019, 01:49 PM   #4
arijaycomet
New Member
7
Rep
16
Posts

Drives: 2015 BMW i8
Join Date: Mar 2016
Location: Cleveland, Ohio USA

iTrader: (0)

Quote:
Originally Posted by zorgzx View Post
Mine did too. But change behavior after 2018 software Or the cold arrived. Have you had software upgraded / tried it in the cold ?
My software is up to date (car was serviced a few months ago). I have had it occur on a VERY cold day, at startup, that the gas motor fires up. I've also had that occur randomly, probably due to a certain # of key cycles that it does so to "check" things.

But I found that even if the gas motor fired up, it goes away after a bit. So it is probably something it does for checksum or similar. Remember, once the gas motor starts, it will not turn off few a little bit until it reaches optimal temps. Starting cold, it will stay on longer that first time until it shuts off.

If you park outside, and have a VERY short drive, the gas motor might come on/stay on for that direction. But if you park in a garage/car park, the gas motor should not fire up regularly unless you request, and the eMode should be 100% electric only.
Appreciate 1
Aye-eight490.00

      01-19-2019, 08:23 AM   #5
Aye-eight
Major
Aye-eight's Avatar
Switzerland
490
Rep
1,169
Posts

Drives: 2015 BMW i8
Join Date: Mar 2015
Location: My garage

iTrader: (0)

Garage List
Quote:
Originally Posted by zorgzx View Post
Mine did too. But change behavior after 2018 software Or the cold arrived.

Have you had software upgraded / tried it in the cold ?
The gas engine self-activates every so often. It happens when itís very cold. It also happens whan the car was parked for more than a week. You have something to do with engine lubrication (making sure nothing goes dry or corrodes), battery conditioning (avoiding full pwer draw from a cold battery) etc.
Appreciate 0
      01-28-2019, 04:22 AM   #6
zorgzx
Private
zorgzx's Avatar
Denmark
11
Rep
60
Posts

Drives: I8 Coupe
Join Date: Aug 2018
Location: Denmark

iTrader: (0)

thaks for the replies. Min however still activates the gas engine every time I go over 80km/h. In E-mode on gentle throttle.
Anyone else have this behavior @ -2 to +5 deg celcius?
Appreciate 0
      01-29-2019, 05:00 PM   #7
Ionicsilveri8
Enlisted Member
8
Rep
35
Posts

Drives: Ionic Silver i8
Join Date: Nov 2018
Location: Devon, UK

iTrader: (0)

I drove to work this morning in e-DRIVE. OAT was 4.5 DegC, managed to get to 76mph on electric only, the motor didn’t cut in but it wouldn’t go any faster. I recall that this is the limit on electric alone. Hope this helps...
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 09:31 AM.




bmw
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST